PHP Version

OptimizePress requires PHP 7 or greater (we recommend 7.4 or above)

If your site is hosted on a server with an older version of PHP, you'll find some features and functions in our editor may not function correctly, and you may experience issues.  We recommend you contact your hosting provider to upgrade to the latest version of PHP available.

Be aware that older versions of PHP may have security vulnerabilities, and also are likely to make your site run slower than more modern versions.  

Compatibility with PHP 8.0 and 8.1

OptimizePress version 3 is fully compatible with PHP 8.0 and 8.1 as of April 2022. Any version updates released after April 15th 2022 and Smart Theme v3 1.0.20 are fully compatible. If you run into any issues with using PHP version 8 or higher just let us know and we'll do our best to help. 

How to increase your PHP version

Some hosting companies have a built in control for this inside your account, but the easiest way to increase your PHP is just to contact your hosting company.  Most now have live chat support so you can just request they increase this and you should be good to go.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.