"Error When Authorizing" - Error Message

If you get "Error when authorizing" error message after you try to license your OptimizePress 3.0 site, it generally means your PHP version is too low. Read below for more details:

Example of error message: 

OptimizePress 3.0 requires PHP version 7.0 or higher. 

One of the requirements for using OptimizePress 3.0 on your site is your site must be running PHP 7.0 or higher.

You can easily check this requirement by going to your WordPress Dashboard (before you install OptimizePress) and navigating to
"Tools > Site Health >> Info >>> Server" like you see here (Site Health is available as of WordPress 5.2.0): 

If you see a PHP version less than 7.0.0 please reach out to your web host for instructions on how you may change the PHP version. They may actually be able to do it for you or guide you on how to upgrade it via your hosting control panel.
 
In most cases, changing the PHP version is not hard to do, however if you have a complex or non standard setup that has been around for several years then you may want to check that your site is functioning properly after your PHP version is upgraded, or check with  a developer for any complex setups to ensure compatibility with PHP 7 (it would be rare to have any issues if you regularly keep your site updated).

All OptimizePress plugins/themes from version 2.0 and up are fully compatible with PHP 7.0 or higher.

Frequently Asked Questions:


Why is PHP 7 a requirement for OptimizePress 3.0?
PHP (recursive acronym for PHP: Hypertext Preprocessor) version 7.0 and up offers the latest standards in Security and Performance. Some older versions of PHP are no longer supported or are only given maintenance updates. We always recommend using the latest stable version of PHP 7.

I also use OptimizePress 2 on my site, can I still upgrade to PHP 7 and will OptimizePress 2 run fine?
OptimizePress 2 is fully compatible with PHP 7. You'll have no trouble with any of our products from version 2 and up.

Can you help me upgrade my PHP?
In some cases yes. If you are using a web host that allows changing the PHP version through the hosting control panel (such as cPanel) then we can usually do this for your without any trouble.
This would be up to the support agent that is servicing your support ticket as we generally do not provide support for your web host, but our senior support team should be able to help with this if you don't have the luxury of waiting for your web host to do it for you. Just make sure we have your hosting logins for cPanel (such as siteground, A2hosting, Hostgator, Bluehost, Knownhost, and other cPanel hosts). So long as you are on a hosting plan that allows access to the PHP controls to change PHP version then we can help. Note that we can not be held responsible for issues that may arise from your request for help in changing PHP version.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.